aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJunio C Hamano <gitster@pobox.com>2009-12-26 14:03:16 -0800
committerJunio C Hamano <gitster@pobox.com>2009-12-26 14:03:16 -0800
commite74f43f9b702ccb88ee83e28de13ccfaebc4abf2 (patch)
treeae30da1b3a75cb017064b497cf5a59d5c30e9b6b /configure.ac
parent902f235378cb2b2f6dd5dd664b9630c95321f0ae (diff)
parentac10a85785baee56bb4a04ad5f847d15ffba0893 (diff)
downloadgit-e74f43f9b702ccb88ee83e28de13ccfaebc4abf2.tar.gz
Merge branch 'sr/vcs-helper'
* sr/vcs-helper: tests: handle NO_PYTHON setting builtin-push: don't access freed transport->url Add Python support library for remote helpers Basic build infrastructure for Python scripts Allow helpers to report in "list" command that the ref is unchanged Fix various memory leaks in transport-helper.c Allow helper to map private ref names into normal names Add support for "import" helper command Allow specifying the remote helper in the url Add a config option for remotes to specify a foreign vcs Allow fetch to modify refs Use a function to determine whether a remote is valid Allow programs to not depend on remotes having urls Fix memory leak in helper method for disconnect Conflicts: Documentation/git-remote-helpers.txt Makefile builtin-ls-remote.c builtin-push.c transport-helper.c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4625b8672b..78345ebb60 100644
--- a/configure.ac
+++ b/configure.ac
@@ -276,6 +276,9 @@ GIT_ARG_SET_PATH(shell)
# Define PERL_PATH to provide path to Perl.
GIT_ARG_SET_PATH(perl)
#
+# Define PYTHON_PATH to provide path to Python.
+GIT_ARG_SET_PATH(python)
+#
# Define ZLIB_PATH to provide path to zlib.
GIT_ARG_SET_PATH(zlib)
#