aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRobert Schiele <rschiele@gmail.com>2007-07-29 20:35:45 +0200
committerJunio C Hamano <gitster@pobox.com>2007-07-31 01:23:43 -0700
commitbef19da9b663044887ecac5ee091ca93567ef331 (patch)
treeac3afb0dfee3c250b4e6a201280a4b471a775769 /configure.ac
parent18508c39c48d457fd095e0e30391471658698a1a (diff)
downloadgit-bef19da9b663044887ecac5ee091ca93567ef331.tar.gz
add option to find zlib in custom path
Some systems do not provide zlib development headers and libraries in default search path of the compiler. For these systems we should allow specifying the location by --with-zlib=PATH or by setting ZLIB_PATH in the makefile. Signed-off-by: Robert Schiele <rschiele@gmail.com> Signed-off-by: Junio C Hamano <gitster@pobox.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 50d2b85ace..b2f196585d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -75,6 +75,9 @@ GIT_ARG_SET_PATH(shell)
# Define PERL_PATH to provide path to Perl.
GIT_ARG_SET_PATH(perl)
#
+# Define ZLIB_PATH to provide path to zlib.
+GIT_ARG_SET_PATH(zlib)
+#
# Declare the with-tcltk/without-tcltk options.
AC_ARG_WITH(tcltk,
AS_HELP_STRING([--with-tcltk],[use Tcl/Tk GUI (default is YES)])