aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEygene Ryabinkin <rea-git@codelabs.ru>2007-03-29 14:06:48 +0400
committerJunio C Hamano <junkio@cox.net>2007-03-31 23:59:47 -0700
commit68daee085cef975c76d9eeba91a3836cf88bcc3f (patch)
treefebf3b8dfa8e0c9d0264ecf15508832145d6cedd /configure.ac
parent6bdb18a9cef9124937941c6e5bd2b645c9da6537 (diff)
downloadgit-68daee085cef975c76d9eeba91a3836cf88bcc3f.tar.gz
Eliminate checks of user-specified Tcl/Tk interpreter.
Do not make the checks on the Tcl/Tk interpreter passed by '--with-tcltk=/path/to/wish' configure option: user is free to pass anything. Signed-off-by: Eygene Ryabinkin <rea-git@codelabs.ru> Signed-off-by: Junio C Hamano <junkio@cox.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 1 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 01fa0f0bda..50d2b85ace 100644
--- a/configure.ac
+++ b/configure.ac
@@ -102,12 +102,10 @@ if test -z "$NO_TCLTK"; then
elif test "$with_tcltk" = "yes"; then
# Tcl/Tk check requested.
AC_CHECK_PROGS(TCLTK_PATH, [wish], )
- elif test -x "$with_tcltk"; then
+ else
AC_MSG_RESULT([Using Tcl/Tk interpreter $with_tcltk])
TCLTK_PATH="$with_tcltk"
AC_SUBST(TCLTK_PATH)
- else
- AC_MSG_ERROR([Tcl/Tk interpreter was not found in $with_tcltk])
fi
fi