aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRalf Wildenhues <Ralf.Wildenhues@gmx.de>2007-11-06 21:12:45 +0100
committerJunio C Hamano <gitster@pobox.com>2007-11-07 17:21:41 -0800
commit3c307bfbe8f8f9223c9b3cef8fdf2fabd05cda6d (patch)
treeef00c3a076d17662ca2a4c1af52a557f140f98b2 /configure.ac
parentfc8b5f0307d5477cb4a52d3b54ff098f8ea34c8e (diff)
downloadgit-3c307bfbe8f8f9223c9b3cef8fdf2fabd05cda6d.tar.gz
Fix minor nits in configure.ac
Avoid "test -o" as it is only XSI not POSIX, and not portable. Avoid exit(3) in test programs in favor of return, to accommodate for newer Autoconf not providing a declaration for exit. Signed-off-by: Junio C Hamano <gitster@pobox.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index ed7cc895d2..bd80517667 100644
--- a/configure.ac
+++ b/configure.ac
@@ -73,7 +73,7 @@ fi \
AC_ARG_WITH([lib],
[AS_HELP_STRING([--with-lib=ARG],
[ARG specifies alternative name for lib directory])],
- [if test "$withval" = "no" -o "$withval" = "yes"; then \
+ [if test "$withval" = "no" || test "$withval" = "yes"; then \
AC_MSG_WARN([You should provide name for --with-lib=ARG]); \
else \
GIT_CONF_APPEND_LINE(lib=$withval); \
@@ -245,9 +245,9 @@ AC_RUN_IFELSE(
[AC_LANG_PROGRAM([AC_INCLUDES_DEFAULT],
[[char buf[64];
if (sprintf(buf, "%lld%hhd%jd%zd%td", (long long int)1, (char)2, (intmax_t)3, (size_t)4, (ptrdiff_t)5) != 5)
- exit(1);
+ return 1;
else if (strcmp(buf, "12345"))
- exit(2);]])],
+ return 2;]])],
[ac_cv_c_c99_format=yes],
[ac_cv_c_c99_format=no])
])